icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.stephanibowlin.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

王者对决彩票 www.3336.hk-078彩票软件下载| www.38699.cc-308彩票蛋蛋| www.97628.com-中国体彩官方| www.081063.com-彩票老师一对一| www.158834.com-爱乐彩是黑网吗| www.334611.com-可以提现的彩票网| www.438208.com-北京体彩一等奖| www.542477.com-淘彩吧唐龙-| www.660734.com-香港意大利彩金项链| www.755736.com-大型网上购彩平台| www.930698.com-玩彩票有什么规律| www.995666.cc-竞彩足彩必胜公式| www.xx8.com-彩神l-| www.ty73.com-南粤风彩票开奖结果| www.17do.com-民政部彩票大案| www.881.net-快三彩票止损方法| www.5887.com-延吉兑彩票站多少钱| www.18425.com-lol彩票广告| www.68606.cc-山东竞彩网-| www.069547.com-福彩3d什么叫跨度| www.145799.com-福彩犯法吗-| www.258813.com-彩票虚拟投注软件| www.340041.com-竞彩高手哥微信| www.439369.com-广西彩票地图| www.539535.com-826购彩能相信么| www.664980.com-福利彩票39期| www.752574.com-彩票猜谜语-| www.852611.com-摩纳哥五分彩骗局| www.919613.com-靠谱的彩票平台程序| www.977284.com-南阳镇平彩礼| www.mr15.com-福利彩票20选5图| www.x44.cc-快钱彩票官网登录| www.62mx.com-福利彩票一等奖税率| www.1064.vip-除了彩名堂还有什么| www.9707.org-转让福彩机怎么过户| www.56129.cc-皇家彩世界手机版| www.006635.com-福彩三d藏机图正版| www.083967.com-福彩今天奖号| www.161226.com-北京彩票站加盟| www.286320.com-彩界发大财-| www.378100.com-体彩大乐透查| www.506677.cc-乐彩网双色球遗漏号| www.581620.com-最新体彩福彩开奖| www.660731.com-有人在玩亚博彩票吗| www.777337.cc-彩票工作工资高吗| www.873553.com-彩41-| www.956885.com-k·h百彩网-| 600万彩票www.187513.com| www.je66.com-福彩快三奖励| www.e89.club-体彩金七乐中奖查询| www.42ao.com-福彩三十六选7彩值| www.646.date-圣地彩是真的吗| www.5003.com-吉祥彩网址-| www.06193.com-3d牛彩网杀跨| www.54576.com-送彩金的新app| www.001260.com-东京15分彩-| www.073389.com-豹赢彩票官方网站| www.144578.com-中国竞彩足球对阵表| www.335962.com-附近体彩-| www.414452.com-彩之云账号怎么注销| www.525258.com-乐聚彩票邀请码| www.639307.com-体彩机器转让多少钱| www.737254.com-彩之网3d相年富途| www.816810.com-彩票命啊-| www.892143.com-竞彩足球历史数据| www.962461.com-双色球彩票中彩网| 聚福彩票www.50989j.com| www.hr33.com-西宁快三查询| www.zp01.com-时时彩为什么害人| www.30vp.com-七彩玫瑰图片| www.1023.hk-彩票网址大全app| www.7755.vip-纽约一分彩开奖查询| www.28917.cc-体彩票11选5结果| www.74449.com-快三骗人模式| www.027061.com-下载彩库宝典| www.102439.com-博众快三彩票| www.834319.com-彩票双色球历史数据| www.897931.com-竞彩店和体彩店区别| www.959352.com-20选5彩票注册| 中国福利彩票www.3478c.cc| www.037376.com-彩票内蒙古快3今天| www.775605.com-163福彩助学金| www.37896.cc-福彩3d专家点评| www.84553.com-山东彩钢板生产厂家| www.037620.com-9cb彩计划-| www.133248.com-得彩近十期开奖号| www.210866.com-吉林新快三走势图| www.283356.com-七乐彩算号公式| www.386537.com-四川体彩中心招聘| www.508806.com-北京人人中彩票| www.579358.com-今晚六禾彩开奖结果| www.653465.com-苏州体育彩票中心| www.766077.com-黑彩平台黑钱报警| www.841630.com-七乐彩买的人那么少| www.908355.com-七乐彩选号最准公式| www.964368.com-卖体彩福彩提多少钱| 幸运彩票网www.33598l.com| www.fg29.com-大发快三全天计划| www.wk06.com-福彩兑奖地点| www.12ne.com-彩票排列三玩法| www.80pm.com-长江彩票app| www.1637.wang-棋牌游戏官网送彩金| www.09685.cc-福彩3d更多期次| www.52287.cc-趣头条彩票-| www.94412.com-极速77彩票平台| www.052327.com-网上彩票如何代理| www.163300.com-彩票外围帮投团| www.246817.com-福彩三d试机号| www.316533.com-体彩大乐透兑奖地点| www.385516.com-吉祥彩登陆-| www.523211.com-刷彩投资-| www.601546.com-彩票流水-| www.672997.com-三d乐彩论坛| www.742829.com-金山彩票app靠谱| www.810285.com-博乐彩票官方网站| www.878757.com-福彩积分怎么下载| 500万彩票www.500pt.com| www.cc66.com-彩神v可不可靠| www.sz70.com-国彩是啥-| www.19ay.com-星期五哪些彩票开奖| www.98uz.com-网络彩票有人控制吗| www.3131.tv-喜悦彩票官网| www.8294.net-福彩3d幸运6点半| www.27653.cc-中国福彩网官网首页| www.66961.cc-福彩中心栗演兵| www.061179.com-微信时时彩骗局| www.134218.com-时时彩黑客改单视频| www.206122.com-网上五分彩可靠吗| www.271443.com-广东新彩王彩图| www.370164.com-分分中彩吧-| www.455940.com-彩票意外中奖故事| www.538478.com-福彩3d大花虎图库| www.636338.com-彩虹糖糖果机| www.716327.com-彩铅画古装-| www.784205.com-彩票一分快三走势图| www.853111.cc-台湾威力彩票| www.910514.com-关注彩票3d-| www.962595.com-大发彩票登陆网址| 818合彩www.www.9889hc.com| www.bw42.com-足彩310什么意思| www.rw64.com-快三选胆码技巧| www.13pn.com-新彩吧画谜-| www.88ck.cc-所有彩票开奖时间表| www.1870.la-q彩98邀请码| www.8660.me-五洲彩票平台靠谱吗| www.36331.com-福彩3d今天什么号| www.76262.com-玛雅吧彩票下载| www.021104.com-老张说彩双色球| www.083982.com-快彩11选五电视版| www.139887.com-绵阳福彩分中心官网| www.208277.com-兰州快三预测豹子号| www.273109.com-福彩刮刮卡在哪进货| www.535708.com-快三过滤软件| www.610592.com-梦见猪推荐彩票号码| www.677468.com-手机上怎么样买彩票| www.746363.com-8亿彩app苹果| www.806311.com-体彩黑龙江11选5| www.873702.com-35彩票官方网站| 爱米彩www.am7588.com| www.wn8.cc-中国彩票开奖公告| www.oe42.com-卓易彩票所有版本| www.9zn.com-瑞彩祥云苹果版网址| www.56av.cc-春秋彩票计划图| www.647.xyz-特彩吧现在开奖结果|